各类产品常见问题

路由

路由无法上网排查步骤

路由上网慢卡顿排查步骤

旗舰版自定义UI有哪些可以自定义?

PPPoE和第三方对接各属性参数

项目 Attributes 属性 取值(实例) 说明
地址池 Framed-Pool 20M 下发地址池
IP 地址 Framed-IP-Address 10.10.0.10 下发 IP 地址
计费更新时间 Acct-Interim-Interval 60 计费更新时间间隔【秒】
限速方式1 RP-Upstream-Speed-Limit
RP-Downstream-Speed-Limit
125/1250 单位为 KB/S,换算 上行 1000kbps
单位为 KB/S,换算 下行 10000kbps
限速方式2 Mikrotik-Rate-Limit 1000k/10000k或1000000/10000000 上行 1000kbps/下行 10000kbps
到期时间 Session-Timeout 86400 86400 秒后强制踢下线
0或不下发此属性表示不强制下线
PPPOE 地址 NAS-IP-Address 192.168.1.254 BRAS与RADIUS服务器连接的接口的IP地址
有可能是内网地址或是外网地址
看RADIUS的部署方式
DNS 下发 MS-Primary-DNS-Server
MS-Secondary-DNS-Server
114.114.114.114
180.76.76.76
主 DNS 可选下发
副 DNS 可选下发
接口 VLAN NAS-Port-Id 10 用户端 VLAN 标识,用于 RADIUS 校验或绑定
踢用户下线 COA 3799 端口 此机制遵循 RFC 3576 此机制遵循 RFC 3576

PPPoE和第三方RAIDUS计费系统支持一览表

计费软件 限速 地址池 到期管理 RADIUS 强制踢下线 选择设备类型
蓝海 支持 支持 支持 支持 Mikrotik/ROS
凌风 支持 支持 支持 支持 Mikrotik/ROS
Radius Manager 3.9 支持 支持 不支持 下一版支持 Mikrotik/ROS
Radius Manager 4.X 即将支持 即将支持 即将支持 即将支持 即将支持
安腾 支持 不支持 不支持 暂不支持 Mikrotik/ROS

内网pppoe用户内网限速或路由WAN口拨号达不到设定速度

各项测速软件并不一致,最准确的测速方式是下载一个指定文件,例如60M,然后计算下载时间如30s,得出的2MB/s 另外在上网时,上级运营商或者路由给的带宽值如100M,仅为理论值,上下行各保留一部分带宽余量,不会满载,更不会上下行同时达到满载。

如何设置VRRP双机热备

VRRP需要有双路由和双外线做冗余备份

两个路由LAN口同网段,下面用户指向虚拟IP 172.16.1.1地址,web登录后进入“应用”-“VRRP双机热备” (此模块为付费模块)主路由和备用路由需要设置相同的标识/虚拟IP地址/通告时间间隔/通信密钥,优先级范围1-255,保证主路由数字大于备路由就行

主路由配置:

备路由配置:

监控物理接口指哪些接口出故障时就切换到备路由

全双备方式:

路由上网卡绑定接口类型选择桥模式

LAN口的桥模式两个网卡一根线路接主核心,一根线路接备核心,主备两路由都采用这种桥模式连接,两核心交换机做VRRP冗余备份。下面的网关指向核心交换机的各个VLAN子接口,核心交换机和路由互作静态路由

在VRRP的触发机制中选择“所有接口”,这样主路由与两核心交换同时断开的情况下才会切换到备路由

配置自定义走线

路由可按源/目的 IP/端口号走线

首先正常配置好多线负载,进入多线负载中的自定义标签页

选择新增规则

名称自定义,优先级填自然数,然后定义走线规则,例如这里自定义192.168.1.100这个IP打开网页时走WAN2

还可以勾选 掉线不自动切换到其他线路,这个主机开网页时都会走WAN2线路

端口映射不成功

首选确定内网主机端口开放(telnet/nc/nmap等工具确认),接着内网另一主机测试确定路由映射的WAN口端口是否通,最后确定在远程主机上测试此WAN口端口是否通。映射的WAN线路不能开启DMZ或者一对一NAT

路由单WAN口通过MAC扩展

此模式适用单条线进入不带VLAN号,含有多个拨号或固定IP的环境

进入”网络”-“虚拟接口” 新增规则标签

名称用WAN+数字,VLAN都填0,MAC地址用后面的随机生成,物理网卡选择与外线相接的网卡,激活后保存

有几个账号就建立几个这样的虚拟扩展

进入广域网(WAN)设置,会多出几个虚拟扩展的标签页

每进入一个标签页,就类似独立WAN口那样设置拨号或者固定IP等

都设置好后按多WAN口汇聚开启各个接口的线路检测,拨号成功后都加入多线负载即可

此模式也可用于带不同VLAN号的虚拟扩展

如何区分公网IP和私网IP

公网IP 全世界任意地方一般都能访问到的

私网IP 无法直接访问到,一般内部访问到的

私网IP格式一般如下三种
10.x.x.x
172.16.x.x至172.31.x.x
192.168.x.x

目前很多拨号为100.x.x.x开头的也为私网地址,直接用浏览器登录IP138

这里的59.173.212.48不为路由WAN口上获得的IP一般就说明使用的为私网IP

缓存

缓存一般部署方式

部署说明:在核心设备(核心镜像交换机或OLT上开启镜像功能),核心设备上配置镜像口和监控口,核心监控口接缓存的镜像口,核心镜像口接路由LAN或OLT,在路由上保证缓存上网正常。

配置缓存的镜像口,如缓存和内网跨了路由区域,到终端用户回包经过三层转发则选择跨路由,下面用户为拨号上网则勾选 加入PPPoE层 , 如内网用户分VLAN则勾选 加入VLAN层

部署缓存无覆盖数排查

  • 缓存可以上网(上网带宽大于10Mbps)

  • 客户机和缓存可以互访

  • 缓存磁盘挂载正常,空余容量充足

  • 镜像设置好对应的配置,是否同路由,是否有PPPoE或VLAN

  • 交换机镜像配置正确,缓存镜像口抓包能得到内网各网段数据

  • 从缓存回包口(默认为命中口)到用户是否有防火墙等安全设备过滤了重定向包

如何确认用户上网数据走缓存?

下载Google浏览器(Chrome)或火狐浏览器,安装成功后,打开浏览器,按F12,再打开网页,按下图所示进行检查,如果Remote Address是缓存的IP地址即成功;

如何理解回源?

回源是针对缓存设备本身,就是当用户去请求某个文件A时,缓存设备作为代理去下载A文件,或者当用户不再去请求A文件时,缓存在闲时也会自动去请求下载完A文件以备后续内网用户下载。

如何理解服务流量?

服务流量就是缓存对内网用户命中产生的流量,简单而言就是节省的外线带宽总流量

如何理解触发系数?

当缓存触发系数设置为0,即表示用户第一次请求网络上某一地址的A文件时,缓存即开始去回源请求A
如果触发系数设置为1,那么用户第一次请求网络上某一地址A文件时,缓存只做记录不做回源,当内网有任意用户再次请求网络上同一个地址A文件时,缓存才会去触发回源。

多个路由共用一个缓存方案

前提条件:
1 所有路由LAN口和缓存需要同一个网段能够互通;
2 共用一个核心交换机,镜像命中均在此交换机上;
3 缓存独立上网外线;
4 每个路由拨号网段不同

镜像模式为同路由+PPPoE模式,是否加入VLAN层根据情况来勾选。命中口不设置网关,用命中口做回传口

静态路由配置每个拨号网段对应路由LAN口

为什么有些站点缓存不了?

缓存仅适用于http协议的,对于https/ftp等协议的无法缓存上

IPTV&ITV

终端视频播放不了排查步骤

终端视频播放卡顿排查步骤

路由下各终端访问不到服务器

网络拓扑环境,IPTV/ITV服务器命中口接内网,命中口与路由器LAN地址同网段,

终端光猫用户一般为拨号到路由或其它NAS上网,下面的用户上网业务正常,访问不到IPTV服务器。(光猫各端口业务一般由OLT上来自定义划分)

环境1:服务器使用命中口上网

这里仅需保证路由器让IPTV上网正常,例如路由上开启了强制拨号或IP/MAC强制绑定,需要把IPTV的命中口IP加入白名单中(允许其不拨号或者不绑定都正常上网),例如秒开路由中将服务器IP加入到“安全”-“黑白名单”中

环境2:服务器单独外线上网

这里需要将拨号网段,加入到静态路由表中,例如PPPoE地址池为10.10.0.0/24

就需要在服务器上添加到这个10.10.0.0/24网段走命中口,进入“系统设置”-“静态路由配置”
添加一条新静态路由

如果仍无法解决请将此问题反馈给对应的路由或实施运维人员,并将任意一台闲置电脑代替IPTV服务器接入内网做测试,下面用户访问得到这台闲置电脑,也就能访问到IPTV服务器

如果为环境1,闲置电脑设置成和服务器命中口同网段,设置网关同IPTV服务器网关

如果为环境2,闲置电脑设置成和服务器命中口同网段,网关为空,cmd中添加静态路由

如何搭建光猫频道抓包环境

PC端安装好wireshark软件

如图,需要有一个镜像交换机(如不会配置镜像可直接使用傻瓜镜像如TL-SF2005)。镜像口接机顶盒,监控口接PC,上联口接光猫TV口,机顶盒正常IPOE/PPPoE/DHCP,看能否正常获取到节目

可以正常收看再打开wireshark抓取各个频道的数据包,将数据包中的播放地址提取出来

下载一个vlc,把抓包的目标地址和目标端口收集起来 填到vlc 网络串流里面进行播放.格式如:udp://239.253.254.249:8000 或者 rtp://239.253.254.249:8000

如果机顶盒上有PPPoE拨号,PC机上也需要拨号后再用VLC测试播放

用电脑VLC上能播放,一般都能在秒开服务器上使用。

无镜像交换机下通过笔记本电脑热点抓包方式

需要一台同时拥有有线和无线网卡的笔记本电脑,然后用网线通过本地连接到光猫IPTV口,地址设置为自动获取IP,笔记本电脑下载安装好wireshark软件,以管理员身份运行命令行

输入下面命令:

netsh wlan set hostednetwork ssid=abc key=12345678 mode=allow

然后回车,即可看到下图显示。注:ssid=网络名 key=密码

然后继续输入下面的东西:

netsh wlan start hostednetwork

会提示 “已启动承载网络。” 这个时候可以通过手机打开无线在列表里面就可以看到abc的SSID无线信号了

接下来在电脑桌面的右下角找到下面的图标,使用右键“打开网络和共享中心”(不同版本的WINDOWS不一样)

然后在弹出的窗口点击 更改适配器设置

然后会发现多了一个无线网络连接2

然后右键点击有线网卡的本地连接,选择属性

出现下面的窗口后,点击共享,勾选上允许其他网络用户通过此计算机的Internet连接来连接,并选择刚才添加的虚拟 无线网络连接2,完成后点击确定即可。

使用运营商的机顶盒连接名称为abc的wifi,输入上面设置的密码12345678,成功连接上电脑发出的无线网络后即可通过运营商的机顶盒观看电视

然后打开电脑上的wireshark进行抓包,双击本地连接

看看是不是关于组播地址的数据包 例如:udp

运行vlc,把抓包的目标地址和目标端口收集起来,填到vlc网络串流里面进行播放.格式如:udp://239.253.254.249:8000 或者 rtp://239.253.254.249:8000

能看的话源地址一般就可以使用了

三层交换机解决ipoe认证方式

首先在交换机上划分vlan,并设置一个trunk口

其次需要配置华为S5700交换机的VLAN设置,配置交换机的1口至8口的VLAN ID号为141—148,设置access模式; 10口做trunk模式,允许VLAN 141—148通过,具体配置如下

最后在交换机上对每个vlan开启dhcp,
interface Vlanif141
ip address 10.10.10.1 255.255.255.252
dhcp select interface

return
disp cu int Vlanif 142

interface Vlanif142
ip address 10.10.10.5 255.255.255.252
dhcp select interface

return
disp cu int Vlanif 143

interface Vlanif143
ip address 10.10.10.9 255.255.255.252
dhcp select interface

return
disp cu int Vlanif 144

interface Vlanif144
ip address 10.10.10.1 255.255.255.252
dhcp select interface

return
disp cu int Vlanif 145

interface Vlanif145
ip address 10.10.10.1 255.255.255.252
dhcp select interface

return
disp cu int Vlanif 146

interface Vlanif146
ip address 10.10.10.1 255.255.255.252
dhcp select interface

return
disp cu int Vlanif 147

interface Vlanif147
ip address 10.10.10.1 255.255.255.252
dhcp select interface

return
disp cu int Vlanif 148

interface Vlanif148
ip address 10.10.10.1 255.255.255.252
dhcp select interface

设置完保存配置后,进入iptv系统设置“网卡绑定”添加一个wan口,并连接华为S5700交换机的10口

完成以后,进入系统设置-上网口配置,在“上网口配置”中打开WAN口,选择“DHCP 自动获取VLAN 模式”,然后在VLAN配置中按下面格式填写,

vlan编号 MAC地址 0.0.0.0
141 00:11:22:33:41:01 0.0.0.0
142 00:11:22:33:41:02 0.0.0.0
143 00:11:22:33:41:03 0.0.0.0
144 00:11:22:33:41:05 0.0.0.0
145 00:11:22:33:41:06 0.0.0.0
146 00:11:22:33:41:07 0.0.0.0
147 00:11:22:33:41:08 0.0.0.0
148 00:11:22:33:41:09 0.0.0.0

注意,上面的MAC地址需要填写运营商机顶盒的MAC地址。

点击“保存”后,稍等一会儿,”VLAN状态框”中就会出现 设备名称,IP地址和网关地址,就说明配置成功了。

进入直播管理—添加组播接受节目源,设置不同的频道走不同的线路。

注:此方式仅适用于无需IPOE服务端验证即可出节目源的场合,如果需要认证上才出节目源的场景不适用

配置WAN口通过交换机VLAN扩展接入方式

交换机的汇聚口接服务器WAN口,交换机的各个VLAN接口接各条外线 (每个交换机配置方式不一样,具体参阅交换机厂商手册)

Web登录服务器,进入“系统设置”->“上网口配置”,进入WAN口标签页,选择 PPPoE拨号VLAN模式,根据提示输入对应的交换机VLAN号和账号密码(MAC地址可以虚拟任意,符号mac格式即可)

全部配置好之后点击下面的连接拨号按钮,链路正常的情况下会正常拨入获得IP

拨号正常后进入上网口标签页,勾选“启用多线路负载均衡”,后续设置组播接收或静态路由按照各自教程即可

单播WAN口自定义走线

适用环境,多条外线接收不同的节目,例如多光猫指定走线环境

单播一般有http/rtsp/rtmp协议

首先需使用独立外线上网,“系统设置”-“上网口设置” 上网口配置标签页中选择独立外线

先确保单WAN口接收此http/rtsp/rtmp节目源正常,再绑定多个网卡启用多线负载

如果是http节目源,可以在设置频道地址时直接指定

如果是rtmp或rtsp节目源,先在频道管理中设置好节目源地址

然后进入“系统设置”-“静态路由配置” 添加对应的静态路由,目标网络填写上例中rtsp后的IP地址,子网掩码选择255.255.255.255,设备名选择指定接收的网卡口名称

如果不知道设备名称可以在“系统设置”-“网卡绑定”中查询到每个WAN口对应的名称

每个不同IP地址的rtmp/rtsp单播配置一条静态路由,同一个IP地址不能配置走两条线路

部分rtsp单播地址播放不了

针对部分rtsp播放不了,需要改传输协议进行接收,进入直播管理-频道管理 修改rtsp的频道,在其最后部分加上参数?ibefore=rtsp_transport*tcp 有时需把最后的tcp换成udp或http再试

对接酒店PMS与数据库

目前支持西软/住哲/金天鹅和以MySQL/MSSQL/Oracle三种数据库为基础的各类PMS系统,不管是云端还是在内网,只要有查询权限就能对接

对接需要询问或自行查询到对接方数据库相关信息,这里以mysql为例做对接配置

输入show databases; 查看账号权限内的数据库,输入use 数据库名称;来进入指定数据库

输入show tables;查看此数据库的表单,再输入select * from 表单名称; 来查询表单各字段内容

综上把对接的账号、密码、数据库名称、表单名称、各字段名称填入到对接页面中

对接测试,点击下面的测试连接,正常情况下会显示 “连接成功” 测试数据输入房间号,可以和数据库中对比,一致即可正常使用了

对接MSSQL示例,使用SQL客户端连接:

登录成功后展开左边列表可以看到数据库名称和表单名称

双击表单即可展开显示各对应字段名称

在服务端对接菜单中填入对应的字段即可

点击下面的测试连接按钮,如果显示“连接成功”即数据库方面对接正常

注意各类PMS系统一定要开启允许远程访问的权限

如何设置直播

对于单播地址,在保证电脑VLC上播放正常的基础上,进入 “直播管理”-“频道管理”,点击 添加频道 按照示例提示直接将单播地址复制到地址栏中

对于组播地址,以224-239开头的IP,需要先设置组播接收

进入 “直播管理” - “组播接收节目源” 点击添加组播源,按下图示例填入组播地址

保存后再进入频道管理中,在组播源下拉列表中直接选择刚添加的频道

保存退出,开启频道,对于非统一接收需要设置静态路由,进入系统设置-静态路由设置,打开静态路由并添加规则,目的网段配置刚设置的组播IP,设备名选择接收组播的网卡

视频源正常即可播放

对于添加组播源统一接收和非统一接收参照下节

组播接收节目中统一接收和非统一接收的区别

1>、统一接收:由接收中间件程序从指定网卡接收

应用场景:

1.组播源IP地址都一样,只是端口不同。

例如:节目源都在组播地址224.1.1.1,端口范围为5000-5050之间

2.接收数据需要队列缓冲的情况

例如:直接接收发现有丢包现象(花屏,卡顿等),可以尝试统一接收

配置方法:

注意:统一接收不依赖静态路由规则。

2>、非统一接收:通过将网卡加入指定组播地址段来直接接收

应用场景:

1.组播源IP地址是一个范围,非固定。

例如:节目源组播地址在238.0.0.1-238.0.0.40是40个不同的台

配置方法:

注意:非统一接收要添加静态路由

在配置中采用以非统一接收为优先选择

如何设置点播

web登录服务器管理界面,确保您服务器存储空间足够,像下图中剩余空间已不足

进入“点播管理” - “点播上传配置”,设置好共享密码,默认都是admin 先点击扫描视频初始化一下

在同一网络下访问服务器点播目录,输入\服务器IP地址

打开 upload 目录,会出现登录框,输入刚才设定的共享密码,默认都是admin

登录成功后,建立各二级目录,如这里的 upload\电影\预告片 然后上传视频到此目录下

或者直接在点播上传配置页面里直接用“上传视频”按钮也可以

指定目录后上传

复制完视频或上传完视频后返回点播上传配置页面,重新点击一下“扫描配置”即可

如何设置电视剧轮播?

进入\IP共享后,在upload之下2级目录建立一个文件夹,将电视剧全部复制到此文件夹下,并在前面以不同集数编号

进入“点播管理” - “点播上传配置” ,点击扫描视频按钮,会出现刚加入的视频

再进入“直播管理” - “频道管理”,点击“添加频道按钮”,在选择轮播源的地方,选择刚添加的电视剧文件夹

开启此频道,首页显示运行中即可观看,轮播会随着数字排序一集集顺着放文件夹中的每个视频

配置多部电影轮播和此方式类似

轮播直播支持的扩展名哪些?

点播 flv mp4 mkv rmvb mpg ts
轮播 mp4

如何设置组播输出节目?

要求:从服务器到终端都要有支持组播设备,例如支持组播的交换机

IGMP组播协议分为v1 v2 v3 所有的设备最好都支持同种版本组播协议

服务端设置:

Web登录设备,直播管理-频道管理,点击添加频道,在IP栏选择“组播输出”,会出现一个组播地址,最好将所有频道设置同一个段内,例如这里的239.9.9.x

系统设置-静态路由配置,添加一条新的静态路由,设备名根据实际情况选择,这里eth0为接内网的网卡

支持组播的设备以华为5700为例配置

进入特权模式

igmp-snooping enable 开启组播管理控制

建立VLAN X,并进入VLAN X

igmp-snooping enable 开启vlan内组播管理控制

所有组播设备设置同一个VLAN,服务器和各个终端都在同一个VLAN内

注意:组播流量与在线观看用户数关系不大,与播放组播的频道数量有关,无论是否有人观看都会占用组播带宽,频道越多组播输出流量越大。如果不是频道数量少用户数量非常大的情况下一般都不采用此种模式

组播接收测试可以用机顶盒直连设备命中口或者用PC直连命中口VLC进行播放测试(直连时节目接收非依赖命中口,如LAN口收组播或设置轮播等)

VLC播放测试验证:

进入组播频道里找到对应的组播地址和端口号

打开VLC 媒体-打开网络串流,输入对应的地址格式 udp://@ + 组播IP + :端口号 最后点击播放,如正常播放说明配置正确

组播口必须从命中口输出,网卡绑定中添加别的网卡作为组播输出也无法登录获取节目列表正常播放

此种接口绑定仅用于卫星接收

如何设置卫星源

卫星源除系统预置频点以外,也能支持自定义卫星源频道
以TBS6909 DVB-S2 8 Tuner PCIe Card卫星采集卡为例,默认可以接收中星6B和亚洲3S的卫星频道

注:两颗卫星无法同时接收,如需同时接收用两张6909的4频点卡

把同轴线接在LNB2口,然后进入 直播管理 - 卫星节目源

根据卫星接收参数设置频道。 频点链接参考

把下行频率、极化、符号率 填入后保存。

点击每个管理频道,在每个频道中修改频道名称

点击频点状态按钮,如果是已锁定状态,则说明是可以接收的。

进入直播管理 频道管理,点击添加频道,选择前面添加并已锁定的卫星源并保存。

保存后启用直播,正常状态首页即可显示对应频道

如何设置部分用户只看部分频道?

进入“用户管理” - “用户组”,先添加任意一个用户组,然后进入此用户组后面的编辑按钮

比如这里勾选10个频道后保存

再进入用户账号中创建新账号,选择刚创建的用户组即可只让此账号看10个频道

为何看直播获取节目列表失败?

1> 服务器未注册或者用户数已达注册上限

2> 服务器无法访问互联网

3> 添加了用户组没有把用户组加到频道管理里面

4> 频道列表服务器的ip不是命中口的ip地址。

5> 内部的网络问题,用户终端和服务器不互通

6> 播放器需要升级到最新,最新的服务端版本加了安全认证,需要新版带安全认证的播放器app

7> 服务端和客户端APK版本不一致,秒开官方尽量做到互相兼容,也有些版本跨度太大无法兼容

打开机顶盒提示登录账号受限?

1> 原用户组或用户误删除

2> 原账号绑定了其它MAC地址,清除即可。进入账号中取消绑定MAC的勾选

3> 服务器磁盘出现坏道导致,数据写入保存不了或用户信息丢失

4> 服务端和客户端APK版本不一致,秒开官方尽量做到互相兼容,也有些版本跨度太大无法兼容

5> 机顶盒到服务器网路不通

内置的共享源怎么用?

系统内自带了几十个内置共享源,服务端更新到最新版,带宽条件满足就可以直接打开使用

共享源都为高清台,对带宽质量需求比较高,需要有独立外线大带宽才能正常打开,一个台5M以上下载带宽

一般共享源作为本地视频频道不够的情况下个别进行补充使用

为什么共享源切台速度比较慢?

共享源是处于全国范围内的一个P2P加速模式,对带宽要求比较高,一定要有比较大的独立外网带宽。并且根据用户需求再去请求占用带宽,在看台的时候是有一个过程,如果第一个人看了CCTV1,开始的时候进去相对慢一些,那么当第二个用户去看同样节目的时候就直接是秒切,因为这个源是有一个请求的过程,5分钟没人看的话不走任何数据,会自动取消外网带宽的占用。
共享源无法回看

应用层组播配置如何使用?

此一般为大型运营商搭建自己的应用层组播,其用户服务器来使用

如自行搭建,需先满足以下需求:
发布服务器 (自带为种子服务器)一台,需要高上传带宽,硬件配置最高,一定要配置固态盘,网卡性能强劲,一定要有独享的固定IP公网地址
种子服务器 (可选配,越多越快)实时接收并中转多节目,在此方案中类似组播交换机功能
用户服务器 (普通IPTV服务器或安装秒开特殊APP的盒子)
条件允许的情况下可建立备份

例如发布服务器有50个频道,每个频道2M码流,那么上传带宽至少需要100M,但对于其同时也为提供连接的种子服务器,带宽需要有冗余,那么上行带宽为300M以上为宜。
种子服务器或用户服务器作为节点给其它终端提供播放,那么其也需要具备一定的上传带宽,整个P2P应用层组播呈现一个分布式结构,例如:
发布服务器200M上行50套节目,10个种子服务器或者用户服务器端接收,这10个设备除了接收外,其各自的500M上行带宽将节目分发给其它需要视频的终端,那么终端用户看视频会从各个种子服务器或用户服务器去多点取节目。

如果都满足后,再将发布服务器远程提供给秒开人员进行调试搭建,搭建好后会给一个组播号,终端用户服务器填此应用层组播号就可以直接使用自己的组播源。

备:从发布服务器到种子服务器或到用户服务器传输都加密;终端用户看同一频道节目会自动从其它多个节点取节目,这个节点是动态实时变化的。

为什么添加视频源,显示也是运行中,内网播放器却放不了?

一般情况下,卫星源有两种编码,一种是mpeg2 ,一种是h264

内网播放器只能播放h264编码,mpeg2的编码需要使用机顶盒安装MQ的APP播放

在编码器中AVC编码模式,电脑端上看不了,只有机顶盒APP才能兼容

怎样调频道列表的顺序?

服务器是根据两点来排序的,数字排序和频道分类

数字排序是自然数由大到小的,大在前,小在后;频道分类是按照 推荐、央视、卫视、省内等顺序来排列的,频道分类为最优先排序,例如进入直播中推荐的40序号就排在央视80之前。可以在分类管理中查看排序或自行添加新类别

首页频道无状态和用户数统计

共享源/组播输出/网络源不预读/源地址下发/单播不预读 这些类型的频道在首页中是 无观看用户统计/无服务流量/无状态显示的

选择源地址下发也无任何H264 ACC等转码

网络源不预读仅对HTTP RTSP有效,当无用户观看此频道时,不预读频道可不占用外网带宽

源地址下发是什么意思?

源地址下发指终端看视频时,不向服务器请求,直接访问源数据地址。用此种模式可以兼容更多码流,更快访问视频源,前提是终端直接访问源要能正常访问到

单播源地址下发,以http为例,频道管理中直接勾选“源地址下发”

组播源地址下发,也在频道管理中勾选“源地址下发”

因为组播要穿透服务器,需要设置静态路由穿透,在静态路由中添加

设备名填写规则为 接收视频源网卡名称->命中口网卡名称 网卡名称可在网卡绑定中查看到

与美视达MSD-3348一体机组播流对接

Web登录美视达MSD-3348,进入“参数设置”-“IP数据流”,点击进入后面的编辑按钮

勾选开关,否则不出流! 如图:

打开TS设置菜单 如图:

双击节目展开节目信息:

需要用到的就是这个ID号,一个通道下面每个节目一个独立的ID号 那么这个节目的组播地址完整格式就是:

udp://@224.2.2.2:2001?pid=1006

然后Web登录服务器

任意指定个IP地址,和子掩码,因为与组播地址无关不冲突,和其它网卡网段不重复即可,接着配置静态路由

目标网络填 调制器通道组播地址 子掩码 选255.255.255.0 IP地址就填:调制器通道地址:224.2.2.2 最后一段都可以变 设备名指定你输入的物理网口确定即可。接着进入频道管理中

将各个频道添加其对应的?pid=xxxx 参数,保存即可配置完毕

酒店版在线商城怎么用

首先保证服务端iso是0256以上,酒店版APK是216以上

web登录服务端之后,在APP推送升级中-酒店超市APP推送 一栏里将 MQHotelMarket_101.apk 上传上去

界面风格选择主题4,并且保持在线订餐启用状态

APK中进入 酒店订餐 中,会弹出一个下载页面

下载更新完毕后重新进入酒店订餐,即可进入商城

如果需要用到云酒店信息,需要在 APP管理-APP通用配置,最底下 在线订餐配置 启用,在线酒店代码填写申请可用的在线酒店代码信息 (此功能目前暂未对外开放)

为何每次进入第三方APP都提示未安装需重新下载安装?

下载APP都应以各应用的TV版为主,移动端版的APP部分存在兼容问题

以爱奇艺的APP为例,先上传指定的APK并命名

客户端第一次接收推送安装后,需要在终端中安装好的应用程序上后找到对应的APK名称

然后将对应的APP名称修改。 注意一定要和终端上的名称完整一致,英文注意大小写

如何在酒店版APK中进入系统设置或登录配置

进入欢迎页后再进入主界面,在主界面依次按遥控器“左上上下右”即可调出隐藏菜单,选择系统设置即可。

其它

如何制作安装启动盘

1.制作安装盘

1.1 制作光盘安装盘

注意:制作安装盘以秒开缓存系统为例,各安装盘以对应系统安装包进行安装。

刻录 ISO 文件到光盘,然后从光盘启动安装。

1.2 制作U盘安装盘

方法一:使用 UltraISO 制作

用到的工具:UltraISO 软碟通 - 点此下载

注意事项:

  1. 某些版本的 UltraISO 制作后可能安装时提示找不到安装源。遇到这种情况,请打开U盘,将ISO文件中的整个boot目录拷贝至U盘的根目录下即可。

  2. 如果通过上述方式制作的U盘无法启动,请在管理工具-》磁盘管理,先删除U盘分区,并重新创建分区(可能U盘包含隐藏分区)并格式化,然后重新制作;

方法二:使用老毛桃U盘工具制作

注:此方法仅适合0969及以后发布的版本

工具下载及详细步骤请点击:老毛桃U盘工具V2013超级装机版

制作完成后,在U盘根目录下创建名为 LMT 的目录,并将ISO文件拷贝进去。

从U盘启动后,选择第10项:启动自定义ISO/IMG文件(LMT目录),回车

接着选择第02项:自动搜索并列出LMT目录下所有文件,回车,选择ISO,回车即可。

方法三:使用大白菜U盘工具制作

注:此方法仅适合0969及以后发布的版本

工具下载及详细步骤请点击:大白菜U盘启动制作工具装机维护版V5.0

制作完成后,在U盘根目录下创建名为 DBC 的目录,并将ISO文件拷贝进去。

从U盘启动后,选择第11项:启动自定义ISO/IMG文件,回车

接着选择第02项:启动自定义ISO/IMG文件(DBC目录),回车

接着选择第02项:自动搜索并列出DBC目录下所有文件,回车,选择ISO,回车即可。

系统安装及Web访问过程

更改主板BIOS设置,从光盘或U盘启动,启动后,会显示如下画面:(这里以安装缓存为例,安装其它系统也类似)

按 ENTER 键启动,加载内核,最后进入安装主界面,如下:

按 ENTER 键开始安装,安装程序将检测安装介质、硬盘等。

如果有多块磁盘,需选择安装的磁盘,按 ENTER 键表示默认安装到第一块磁盘上。

等待安装程序对硬盘初始化、拷贝文件等。

接着进入配置管理接口,依次输入IP地址、子网掩码、网关IP:

最后完成安装:

根据提示,将缓存系统接入到局域网中,任意一个网卡插入网线,并在另外一台计算机上通过web访问其配置界面。

保证到服务器的物理线路连接正常,计算机设置 192.168.1.x的IP地址,然后在浏览器地址栏中输入 http://192.168.1.254 进入web管理登录

输入默认的账号密码admin 登录后,进入配置主界面:

如何设置云登录远程协助?

web登录服务器,系统工具 -> 远程协助 设置一个云登录标识(最好设置一个不常见复杂一些的标识),然后勾选启用自动连接即可

当出现远程web连接地址,即可将此地址及账号密码发给秒开相关人员做后续处理

需保证设备上网正常才能远程连接成功

Web密码忘记了如何重置

秒开所有设备都可以接入显示器和键盘进入控制台,进入控制台后选择1修改Web管理的用户名及密码(此为超管账号)

如何添加磁盘

先确保在硬件底层BIOS中识别到磁盘,然后web登录系统,进入“系统设置” - “存储磁盘配置”,找到最底下的磁盘,将磁盘后面的 加入存储池 点击一下,系统会自动初始化

初始化完毕之后就可以供系统使用了,初始化会格式化整个磁盘,使用前请备份好整个数据

如果下面无磁盘显示,请将远程协助发给秒开相关人员

多核的CPU安装完成后在系统里面只显示为单核

如果CPU的确是多核,主板支持没问题,则可能和bios设置有关系,设置方法如下:

开机自检时,按Del进入 BIOS 设置(根据硬件的不同,也可能其他键,如F2等)进入 Advanced -》CPU Configuration (高级-》CPU 配置)

在下面的选项中,找到 Cores Enabled (开启的CPU核心数量),设置为0 (0表示开启所有核心,如果设为1表示只启用1个核心,2表示双核… 依此类推) 有的BIOS为 Active Processor Cores 选择All 找到 X2APIC (X2APCI 支持),设置为 Disabled(禁用)

修改完成后,保存BIOS设置(F12或其他键)退出,设备重启后进入系统即可

硬盘识别不了或者4T硬盘仅识别出2T

如果系统是单独的,只做数据盘,可以支持大于2T。如果系统盘和数据盘共用同一硬盘则最大2T

有些主板不支持4T硬盘,需要先在BIOS里查是否识别到4T,如果BIOS识别后系统仍无法识别,则将硬盘接好后将远程协助等信息发给秒开人员。

如何添加NAS网络磁盘

NAS网络磁盘是需要访问到NFS服务端才可以挂载上去

NFS服务端linux端搭建需要安装 nfs-common nfs-kernel-server portmap 等套件,具体方式请自行搜索,搭建完后一定要给与待挂载目录读写权限

最后看下共享情况,输入 showmount -e 一定要有其待挂载目录显示

在服务器上存储磁盘配置中填入linux的IP和刚显示的待挂载目录,点击挂载,提示成功后即可和本地磁盘一样操作使用

NFS的win下安装自行下载软件开启NFS服务,如这里hane win NFS为例,编辑其export文件

设置好后一般重启一遍nfs服务,挂载路径填写/加上刚才的挂载名称即可

群晖NFS对接配置参照
http://777.5ihome.net/345.html

对接群晖主要步骤:

需要开启NFS服务

文件夹的NFS权限设置可读写所有网段都可以访问

其它如 FREENAS也可对接,具体设置参照此系统文档

挂载成功后,所有视频都需要放在挂载目录下建立的子目录中才能扫描使用

需要在挂载路径下建立各个子目录并放入视频

注意NFS挂载路径不要有中文

PPPoE用户访问不到IPTV或缓存

这种情况一般需要配置两个地方

1> 在路由修改配置(注意:有些路由是不需要添加配置就可以的)

Panabit:

ROS:

2> 在MQ服务器上添加静态路由

静态路由配置方式汇总

对于IPTV/ITV来说一般非统一接收组播设置静态路由配置设备名称,单播接收配置指定网关

1 接收组播地址:224~239开头的IP

这里的网关都填写为0.0.0.0,设备名称为网卡绑定中对应的ethx接口,如这里的eth3就是指WAN5口

这种模式需要注意的是子网掩码根据需要来调整,例如节目的组播地址很多224.1.0.3/ 224.1.0.4/224.1.0.5等都是由一个网卡接收,那么这里的子网掩码就选择255.255.255.0
如果是同一个段地址多个网卡接收,就需要填类似这里的255.255.255.255,这样就需要每个组播地址设一条静态路由指定走哪个网卡接收

2 接收单播地址:非组播外都为单播,这里以rtsp为例

例如这里频道中有个单播rtsp源地址

将此IP加入到静态路由中后,设备名留空,用网关下一跳来指定走线

这里是指定走WAN4口的网关

如果是需要单播走命中口则网关IP填入这里的网关地址

如果有多个WAN口同IP,如WAN1-WAN5都DHCP或拨号获取的是192.168.1.1的地址,则需同时填入设备名和网关地址

3 对于IPTV/ITV组播输出也需要加静态路由,例如服务器频道中选择组播输出时会出现默认的239.9.9.9的IP地址

添加静态路由和组播接收一样需要指定它输出时走哪个网卡设备名,一般为命中口

对于缓存来说有两种情况需要加静态路由

1 缓存需要独立上网时

像这种缓存有单独外线连接到互联网,当内部用户IP段处与和缓存命中口同网段时(图中左下部分用户),可以不用设置静态路由即可和缓存通信,当内部用户IP处于和缓存命中口不同网段或者PPPoE拨号段时,需要添加静态路由

2 命中口网关为三层交换机,内网走线全部依赖三层的静态路由时

下面各个设备网关为核心三层交换机上的VLANIF接口,缓存命中口也是连的其中VLANIF接口之一,这种模式下做静态路由还要绑定其交换机上的MAC地址

如IPTV/ITV服务器和此两种网络拓扑相同,内网终端用户访问不了时也和此缓存配置静态路由方法类似

无论哪个设备和各接口同一网段无需添加静态路由,如这里命中口 LAN WAN分别是192.168.1.0/24 192.168.2.0/24 192.168.3.0/24

那么再无需添加各个接口本身网段的静态路由

注意无论哪种网络设备同一个设备内所有IP地址不要同网段,例如设置了一个LAN口192.168.1.254/24,就不要设置一个WAN口192.168.1.100/24

怎么配置链路汇聚

有时普通千兆口不够使用,需要多千兆口进行带宽叠加,这时就需要链路汇聚,配置链路汇聚需要服务器有多余的网卡口,支持链路汇聚的交换机或OLT设备

web登录服务器,进入“系统设置” - “网卡绑定” 点击后面的编辑按钮

汇聚模式这里以动态链路汇聚为例,勾选下面用作汇聚的所有网卡

保存后服务器方面即设置完毕,再进入对端设备进行配置

华为交换机为例,进入特权模式

interface Eth-Trunk1
port link-type trunk
port trunk allow-pass vlan 2 to 4094
mode lacp-static //修改链路聚合模式
max active-linknumber 3 //设置最大活动链接数为3
bpdu enable //开启BPDU
lacp priority 100

interface GigabitEthernet0/0/1
eth-trunk 1
undo ntdp enable
undo ndp enable

interface GigabitEthernet0/0/2
eth-trunk 1
undo ntdp enable
undo ndp enable

interface GigabitEthernet0/0/3
eth-trunk 1
undo ntdp enable
undo ndp enable

OLT 5680T为例,config模式

link-aggregation 0/19 0 0/19 1 egress-ingress
workmode lacp-static
link-aggregation add0member 0/19/0 0/19 1
save

最后将这几个网卡对应的线路连接到对端汇聚设备即可

交换机设置镜像

对于缓存工作或者光猫抓包等,需要用到镜像交换机,这里以s5700为例 (括号内的无需输入)

sys (进入特权模式)
observe-port 1 interface GigabitEthernet 0/0/2 (设置观察端口.2)
interface g0/0/1
port-mirroring to observe-port 1 both (设置被镜像口为1口)
quit
quit
save

需要特别注意的是交换机的被镜像口是用于镜像数据,观察监控口是接秒开缓存的镜像口或者抓包的机器

例如这里PC端安装好wireshark后可以收到镜像过来的非本地IP数据(source为各个不同源IP不仅仅是PC端自己的IP)

缓存上进入“系统工具”-“实时抓包” 网络接口选择 “镜像口” 数据包个数填 “5000” 然后点击 开始 按钮进行抓包,抓包完成后打开,一般都抓出较大数据包就说明配置组镜像成功

配套交换机推荐

镜像交换机 华为 5700系列/H3C 5500系列

单WAN多拨交换机 华为 S2700系列

POE供电交换机 H3C S1208-PWR

文档更新时间: 2019-01-23 17:36   作者:陈代山